Close

McSally On Gutting Pre-Existing Conditions Coverage: “We Gotta Get This Done”

In response to Congresswoman Martha “McShifty” McSally’s interview this morning where she pledges once again to vote for the GOP’s toxic health care agenda that will increase premiums and jeopardize coverage for pre-existing conditions for 2.8 million Arizonans, Democratic Senatorial Campaign Committee spokesman David Bergstein released the following statement:

“Congresswoman McSally told Arizonans exactly why she can’t be trusted in the Senate — she’s going to keep voting for higher health care premiums and to cut coverage for pre-existing conditions. It’s the same damaging and expensive health care agenda she’s pushed for years, and it’s one of the most important reasons voters will hold her accountable in November.”

In 2017, Congresswoman McSally urged her colleagues get “this fucking thing done” and then voted for the GOP’s health care bill that imposes an age tax, spikes health care premiums and cuts coverage for pre-existing conditions. She’s also refused to oppose the GOP-led lawsuit that would eliminate protections for pre-existing conditions.

 

###

Next Post

GOP Pre-Existing Conditions Lawsuit a “Serious Threat” to Americans’ Coverage


Fatal error: Uncaught exception 'Facebook\FacebookThrottleException' with message '(#4) Application request limit reached' in /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/features/grabfeeds/includes/facebook-php-sdk-v4-4.0-dev/src/Facebook/FacebookRequestException.php:117 Stack trace: #0 /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/features/grabfeeds/includes/facebook-php-sdk-v4-4.0-dev/src/Facebook/FacebookRequest.php(280): Facebook\FacebookRequestException::create('{"error":{"mess...', Object(stdClass), 403) #1 /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/features/grabfeeds/includes/feeds.php(55): Facebook\FacebookRequest->execute() #2 /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/features/grabfeeds/load.php(16): require_once('/nas/content/li...') #3 /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/slices/update.php(3): get_feeds() #4 /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/boilerplate.php(37): i in /nas/content/live/dscc/wp-content/themes/wideeyecreative/includes/features/grabfeeds/includes/facebook-php-sdk-v4-4.0-dev/src/Facebook/FacebookRequestException.php on line 117